Pages

Search

(Solution) Reload iptables on every boot

Hi, To be able to load your iptables ruled every time your Linux system is restarted just follow these commands.$ sudo iptables-save /etc/firewall.conf Open /etc/network/if-up.d/iptables and add: Provide executable permission:$ sudo chmod +x /etc/network/if-up.d/iptable Now, your iptable rules will be loaded every time your Linux box is booted. If you need to modify your rules just execute:$ sudo iptables-save /etc/firewall.conf Regards,Rubén

(Solution) How to change the screen resolution Kali Linux using Hyper-V

Hi, In order to change the screen resolution to a Kali Linux using Hyper-V follow these steps: Add these lines to this file:sudo vim /etc/initramfs-tools/modules In the terminal type:sudo update-initramfs -u Reboot. sudo nano /etc/default grub GRUB_CMDLINE_LINUX_DEFAULT=»quiet splash video=hyperv_fb:1920×1080″sudo update-grub Regards,Rubén

(Solution) KDE Plasma Icons-only Task Manager and regular Task Manager broken after update on Antergos

Source : https://www.reddit.com/r/kde/comments/9uu1zx/iconsonly_task_manager_and_regular_task_manager/ Hi, Last day after a small update on my Antergos system with KDE plasma something went wrong and my task manager broke down.Looking around the task manager and the icons, this error pop up appeared. Error loading QML file: file:///usr/share/plasma/plasmoids/org.kde.plasma.taskmanager/contents/ui/main.qml:26:1: plugin cannot be loaded for module «org.kde.taskmanager»: Cannot load library /usr/lib/qt/qml/org/kde/taskmanager/libtaskmanagerplugin.so: (libprocesscore.so.7: cannot open shared object file: No such file or directory) After finding the source url

Radare 2 install – Mac OS X Code Signing

Hi,As I am a Mac user, I have faced a Mac OS X Code Signing issue. After a little research, I found a site with all needed steps described.The site can be found [here](http://manual.freeshell.org/radare2/osx.md) The required steps are (copy-pasted from this site):Mac OS-X Users need to follow some extra steps to get the radare2 program signed and ready to debug other applications without running it as root.Same happens for iOS

Kali linux 2017.3 released

Hi, A new Kali release (2017.3) has been launched. If you want to check all included changes please read this site If you need to install it from scratch or for a first time, please read the documentation that can be found here. This distro can be downloaded from here. If you have already installed a previous release, execute these commands to upgrade your system to the latest release.# apt

(Solution) How to compile a 32 bits application using a 64 bits linux system with gcc

Hi, In order to be able to compile a 32 bits application if you are using 64 bits Linux,  -m32 modifier needs to be used. $ gcc hello.c -m32 -o hello.out will create a 32 bits application.$ gcc hello.c -m64 -o hello.out will create a 64 bits application. Regards,Rubén

List of open ports in your Linux machine

Hi, To obtain a list of open ports in your Linux machine just need to type: netstat -an –inet | grep LISTEN | grep -v 127.0.0.1 Regards,Rubén

(Solution) How to enable 32 bit support to a 64 bit ubuntu system

Hi, Days ago I found a problem running a linux binary. After checking everything I could, it still couldn’t be executed. I finally realized  that the binary was a 32 bit binary and my system was a 64 bit Ubuntu 17.04After some Google search I found a solution: Enable the i386 architecture (as root user): Install 32-bit libraries (as root user): Regards, Rubén

Find listening network ports

Hi, To obtain a list of all the open ports of your system and which are the associated applications to them just execute command: netstat -tulp ip or nmap -sT -O ip

JSDetox installation

According to its main site JSDetox is a Javascript malware analysis tool using static analysis/deobfuscation techniques and an execution engine featuring HTML DOM emulation. To install it just execute these steps: (These actions have been tested using a Kali Linux installation) Requisites to be able to install JSDetox are: git- ruby- ruby-dev libxslt1-dev- libxml2-dev build-essential It may appear this error: The installation of therubyracer 0.9.8 has a problem and can’t