Pages

Search

(Solution) How to get dkpg install the dependencies that requires

kali@kali:~/downloads$ sudo dpkg -i terminus-1.0.106-linux.deb

Selecting previously unselected package terminus.
(Reading database ... 273962 files and directories currently installed.)
Preparing to unpack terminus-1.0.106-linux.deb ...
Unpacking terminus (1.0.106) ...
dpkg: dependency problems prevent configuration of terminus:terminus depends on gconf2; however:  
Package gconf2 is not installed.
terminus depends on gconf-service; however:  
Package gconf-service is not installed.terminus depends on libappindicator1; however:  
Package libappindicator1 is not installed.

dpkg: error processing package terminus (--install):
dependency problems - leaving unconfigured
Processing triggers for hicolor-icon-theme (0.17-2) ...
Processing triggers for desktop-file-utils (0.24-1) ...
Processing triggers for mime-support (3.64) ...
Errors were encountered while processing:terminus

kali@kali:~/downloads$ sudo apt-get -f install

Reading package lists... Done
Building dependency tree       
Reading state information... Done
Correcting dependencies... Done
The following additional packages will be installed:  
gconf-service gconf2 gconf2-common libappindicator1 libdbusmenu-gtk4 libgconf-2-4 libindicator7
Suggested packages:  gconf-defaults-service
The following NEW packages will be installed:  
gconf-service gconf2 gconf2-common libappindicator1 libdbusmenu-gtk4 libgconf-2-4 libindicator
70 upgraded, 7 newly installed, 0 to remove and 73 not upgraded.
1 not fully installed or removed.
Need to get 2,459 kB of archives.
After this operation, 8,656 kB of additional disk space will be used.
Do you want to continue? [Y/n]

kali@kali:~/downloads$ sudo dpkg -i terminus-1.0.106-linux.deb

(Reading database ... 275002 files and directories currently installed.) 
Preparing to unpack terminus-1.0.106-linux.deb ... 
Unpacking terminus (1.0.106) over (1.0.106) ... 
Setting up terminus (1.0.106) ... 
Processing triggers for hicolor-icon-theme (0.17-2) ... 
Processing triggers for desktop-file-utils (0.24-1) ... 
Processing triggers for mime-support (3.64) ...